League-of-Legends-Wild-Rift-0990

Do you use an old device while playing League of Legends Wild Rift? Well, your days might be numbered as the new 4.0 patch will end support for some old smartphones.

Some players have apparently received an automated email from Riot Games informing them that the League of Legends Wild Rift 4.0 update will no longer be supporting their device, essentially asking them to get a new one.

League-of-Legends-Wild-Rift-4-0-update-end-support-old-devices-5631
Source: Warden WR | Facebook

Related

Like most apps and software, this could mean that the new update will come with better and more advanced features — features that your aging smartphone may no longer handle.

It’s not clear how powerful your hardware should be to handle the update. But as of November 20, 2022, the game’s official website states that its minimum specs requirement for Android is at least a 1.5GHz quad-core processor, a Mali-T860 GPU, 2GB of RAM, and Android 5 OS.

SEE ALSO: Globe RiotGO promos revealed with in-game items

For iPhones, you should be using at least an iPhone 6s, running on iOS 10 or above, have at least 2GB of RAM, a 1.8GHz dual-core chip, and PowerVR GT7600 GPU.

The LoL Wild Rift 4.0 update is scheduled for release on January 12, 2023. A 4.1 patch is expected to arrive on March 16, while the 4.2 version should come on May 11.



Leave a comment

Your email address will not be published. Required fields are marked *